1. Hello Guest,

    We wanted to let you know that the NXS17 templates and viewers have been released!

    Grab them HERE
  2. Hello Guest,

    We wanted to let you know that besides the NXS17 templates and viewers, now we have released the NXS17 Mod as well!

    Grab the latest files HERE
  3. Hello Guest,

    We wanted to let you know that we are trying out a new feature at SRD. Your feedback is needed!

    Read more about the chatbox HERE
  4. Hello Guest,

    We are gauging interest in starting an online racing league.

    Please take a moment and give your vote HERE. Thanks!

NR2003 FPS Drops After About 12-15 Minutes

Discussion in 'NR2003 - PC Support and Troubleshooting' started by Larson42Fan, Aug 9, 2018.

  1. Larson42Fan

    Larson42Fan New Member

    Messages:
    3
    Likes Received:
    2
    Hello all, I have a problem when watching races on NR. After about 12-15 minutes the FPS drops continuously as time goes on. It never recovers, no matter what track or what mod. My drivers are up to date. It is really frustrating because all I'd like to do is do a sim season, but cannot have races longer than 15 minutes without this issue. I've run out of ideas, as even on the graphics lowest settings it still behaves this way. Below are my specs:

    Graphics: GeForce GTX 750
    Processor/CPU: Intel Core i7-3770 CPU @ 3.40GHz
    RAM: 10GB
    OS: Windows 10 64-Bit
    Motherboard: PEGATRON CORPORATION 2AD5 (SOCKET 0)

    Looking for any suggestions to help resolve this issue. Any help is appreciated. Thanks in advance!

     
  2. bvc

    bvc Stupid Sexy Taysom

    Messages:
    2,093
    Likes Received:
    2,122
    Try downgrading your graphics drivers.
     
  3. timnsr72

    timnsr72 Well-Known Member

    Messages:
    184
    Likes Received:
    61
    Throttling due to overheating maybe...
     
  4. Rufio2031

    Rufio2031 Well-Known Member

    Messages:
    67
    Likes Received:
    86
    I was going to say as well, you might want to monitor your temps. Could be overheating.
     
  5. Fixer1140

    Fixer1140 New Member

    Messages:
    1
    Likes Received:
    0
    I have pretty much the same problem, although the game starts to lag after 15 seconds, even on the main menu and becomes completely unplayable after a minute or so. Yesterday everything worked like a charm. Nothing wrong with temps or cpu/gpu workload.
    I7-4790k
    Gtx 1070
    16 GB RAM
    Win 10 64bit
     

Share This Page